Форум о хостинге
16 ЅЮпСам 2018, 03:11:07 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.

Войти
Новости: SMF форум только что установлен!
 
   Начало   Помощь Поиск Войти Регистрация  
Страниц: [1]
  Печать  
Автор Тема: Apache под win2000pro (127.0.0.1 и код 400)...?  (Прочитано 3769 раз)
Гурон
Новичок
*
Сообщений: 4


Просмотр профиля
« : 15 ДХТаРЫм 2003, 01:56:48 »

при обращении к хосту 127.0.0.1 localhost получаю 400
при обращении к виртуальному хосту 127.0.0.2 serv1 получаю нормальную работу !

значит: адрес 127.0.0.1 юзает кто-то или что то в Win2000pro webhostingtalk.ru/ib3/non-cgi/emoticons/rock.gif? как освободить для апача

(iis не устанавливал, httpd.conf рабочий и прооверенный.)
Записан
Egorov Sergey
Новичок
*
Сообщений: 347


Просмотр профиля
« Ответ #1 : 15 ДХТаРЫм 2003, 11:27:18 »

Точна не робит 127.0.0.1 webhostingtalk.ru/ib3/non-cgi/emoticons/mad.gif

Вот только зачем он нужен 127.0.0.1? webhostingtalk.ru/ib3/non-cgi/emoticons/smile.gif
Записан
Гурон
Новичок
*
Сообщений: 4


Просмотр профиля
« Ответ #2 : 16 ДХТаРЫм 2003, 00:40:56 »

оно мне надо чтобы локально отлаживать сайтики скриптики. установлен apache 1.3.26 под win2000pro.

проблема оказалась в wingate 4.5.1 - в нем есть WWW Proxy server который работает на 80 порту.

что мне удалось сделать:
поставил апач на порт 8080, в wingate-e WWW Proxy server оставил на порте 80,
на вкладке Non-Proxy Requests указал Pipe request through predetermined server,
указал сервер 192.168.0.1 и порт 8080.

Получил следующее:
при обращении в браузере к хосту 127.0.0.1 localhost получаю все как положено !
при обращении к виртуальным хостам 127.0.0.2 serv2, 127.0.0.3 serv3.... получаю
в браузере "Не удается найти сервер или ошибка DNS Internet Explorer"

вот как разрулить такую ситуациюwebhostingtalk.ru/ib3/non-cgi/emoticons/rock.gif?webhostingtalk.ru/ib3/non-cgi/emoticons/rock.gif?webhostingtalk.ru/ib3/non-cgi/emoticons/rock.gif?webhostingtalk.ru/ib3/non-cgi/emoticons/rock.gif?webhostingtalk.ru/ib3/non-cgi/emoticons/rock.gif?webhostingtalk.ru/ib3/non-cgi/emoticons/rock.gif

(пробывал по всякому но лучшее что получал так это то что все менялось местами - serv2 работал, localhost - нет.)
Записан
Sergio
Новичок
*
Сообщений: 216


Просмотр профиля
« Ответ #3 : 16 ДХТаРЫм 2003, 07:28:37 »

Настройте name-based virtual host.

В файле hosts (c:\winnt\system32\drivers\etc\hosts) создаете запись типа 127.0.0.1 cooldomain.local, а в конфиге апачи примерно следующее:

<table border="0" align="center" width="95%" cellpadding="0" cellspacing="0"><tr><td>Исходный код </td></tr><tr><td id="CODE">
### Section 3: Virtual Hosts
NameVirtualHost 127.0.0.1

<VirtualHost cooldomain.local>
ServerAdmin webmaster@cooldomain.ru
DocumentRoot "C:/InetPub/cooldomain.ru/public_html"
<Directory "C:/InetPub/cooldomain.ru/public_html">
Options Indexes Includes
AllowOverride All
Order allow,deny
Allow from all
</Directory>
ScriptAlias /cgi-bin/ "C:/InetPub/cooldomain.ru/public_html/cgi-bin/"
<Directory "C:/InetPub/cooldomain.ru/public_html/cgi-bin">
AllowOverride None
Options ExecCGI
Order allow,deny
Allow from all
</Directory>
ServerName cooldomain.ru
ErrorLog "C:/InetPub/logfiles/cooldomain.ru.error.log"
</VirtualHost>
[/QUOTE]

ну и так далее... У меня работает без проблем.
Записан
Гурон
Новичок
*
Сообщений: 4


Просмотр профиля
« Ответ #4 : 17 ДХТаРЫм 2003, 19:34:32 »

для виртуальных хостов и при одновременной работе апача и wingate
Записан
Egorov Sergey
Новичок
*
Сообщений: 347


Просмотр профиля
« Ответ #5 : 17 ДХТаРЫм 2003, 20:44:11 »

НУ удалось заставить их работать вместе?
Записан
Гурон
Новичок
*
Сообщений: 4


Просмотр профиля
« Ответ #6 : 17 ДХТаРЫм 2003, 22:28:34 »

работает тотлько локалхост. виртуальные хосты не работают.
Записан
Страниц: [1]
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2008, Simple Machines LLC Valid XHTML 1.0! Valid CSS!